WordPress 3.4 compatibility

As you might be aware WordPress 3.4 is now at the release candidate stage. The BuddyPress team believes the current version of BuddyPress (1.5.5) is fully compatible with WordPress 3.4. If you find any issues with BuddyPress when testing WordPress, please let us know by starting a discussion on our support forums or by filing a bug report on our Trac.

For developers testing WordPress with WP_DEBUG, we know that the BP Default theme generates deprecated function notices, and have already fixed these in our 1.5 branch on SVN.