BuddyPress Dev Updates

Legacy Forums support will be…

Legacy Forums support will be removed with BuddyPress #3.0, due for release next year.
If your site is still using Legacy Forums, you will need to migrate to bbPress 2. Backwards compatibility will be ceased.
The last planned BuddyPress release that will support Legacy Forums is #2.9.3.

“Legacy Forums” is what we call the bundled version of bbPress 1 that has shipped with BuddyPress for over nine years. In fact, bundled or not, bbPress 1 only runs on WordPress versions older than 4.7, because a conflict between something called BackPress, which is nested inside bbPress 1, and the WP_Taxonomy class introduced in WordPress 4.7. So: if you’re using bbPress 1 today, you must be using an old version of WordPress, otherwise your site is broken.

This withdrawal of support is something that has been discussed for the last four years (see tickets 5351, 7502), and we feel now is the time. We will be including compatibility fixes for Legacy Forums with the upcoming BuddyPress 2.9.3 (date tbc) to help assist with any sites that are about to migrate to bbPress 2.

The removal of Legacy Forums from trunk will happen very soon.