BuddyPress 5.0.0 will require WordPress…

BuddyPress 5.0.0 will require WordPress 4.7 or greater. See https://buddypress.trac.wordpress.org/ticket/8025, as well as the perennially ripping read, https://codex.buddypress.org/getting-started/wordpress-version-compatibility/.