WordPress required version update

Hi !

Please note that BuddyPress 7.0.0 will require WordPress >= 4.9.

To learn more about this change: https://buddypress.trac.wordpress.org/ticket/8318

To learn more about how we decide to bump our WordPress required version: https://codex.buddypress.org/getting-started/wordpress-version-compatibility/

#7-0-0, #wp-requirements

In accordance with our WP…

In accordance with our WP compatibility policy, BuddyPress 2.8 will require WordPress 4.3. See https://buddypress.trac.wordpress.org/ticket/7350.

#2-8, #wp-requirements

BuddyPress 2.5 will require WordPress 3.9

Previously: https://bpdevel.wordpress.com/2015/08/06/wp-version-compatibility-guidelines/

In accordance with our WP compatibility guidelines, we’ll be dropping official support for WP 3.8 in BuddyPress 2.5. For more details, see #6805.

#2-5, #6805, #wp-requirements