WP version compatibility guidelines

Growing out of some discussions between team members over the last year or two, along with some musing on https://buddypress.trac.wordpress.org/ticket/6258, I’ve drafted a page explaining our WP version compatibility guidelines: https://codex.buddypress.org/wordpress-version-compatibility/ I’m sure that anyone reading this site always runs WP bleeding on their sites😉 but if you have any thoughts on these guidelines, please feel free to comment here.

On a related note, BuddyPress 2.4 will require WP 3.8. We will no longer actively build workarounds for WP < 3.8, and 3.7 will be removed from our Travis matrix (3.6 was already untested – 3.7 was when the /src transition took place). See https://buddypress.trac.wordpress.org/changeset/10031 and https://buddypress.trac.wordpress.org/ticket/6258#comment:9.

#travis, #wordpress